Desktop Connect

In folgendem Artikel wird erklärt wie Sie Desktop Connect herunterladen und richtig verwenden können, sowie einige Fehlermeldungen beheben können.

Desktop Connect wird dafür verwendet, Dokumente direkt im Projektraum zu bearbeiten und neu einzustellen, ohne diese herunterladen zu müssen.

Ihr Projektansprechpartner kann Ihnen eine Auskunft darüber geben, ob Desktop Connect an Ihren Projektraum angebunden ist. Sollte dies nicht der Fall sein und eine Anbindung an Desktop Connect wird benötigt, besprechen Sie dies mit Ihrem Projektleiter. Dieser muss eine Anfrage an unser Team schicken, um die Anbindung des Projektraumes zu besprechen.

Wie wird Desktop Connect installiert

Laden Sie sich zuerst die Desktop Connect Installationsdatei herunter, diese finden Sie am Ende dieses Artikels.

Der TP DC-Client wird bei der Installation in das Verzeichnis „C:\Program Files(x86)\think project!\DesktopConnect“ kopiert.
Zusätzlich muss Lese- und Schreibzugriff auf alle weiteren Verzeichnisse bestehen, die weiter unten unter „Verzeichnisse“ angegeben sind.

Update

Die Installation des Updates funktioniert wie die Erst-Installation. Der TP DC-Client orientiert sich an der Installation der Thinkproject Instanz. Grundsätzlich wird zwischen Minor-und Major-Updates unterschieden.
Bei Minor-Updates wurden nur Änderungen vorgenommen, die die Sicherheit der Software nicht beeinträchtigen. Minor-Updates müssen nicht unbedingt installiert werden.
Sicherheitsupdates bzw. größere Umbauten kommen als Major-Update und werden entsprechend angekündigt. Sie müssen installiert werden. Die Kommunikation zwischen der TP-Instanz und einem älteren Client wird unterbunden.

Bei Major Updates ist der Nutzer gezwungen, das erforderliche Update zu installieren.

Sprach-Einstellungen

Programm-Oberfläche: System-abhängig (die Programm-Oberfläche wird geöffnet über
Start → Programme → Thinkproject Desktop Connect)
Meldungen bei der Kommunikation: Projektsprache des Thinkproject Projektes

Installationsinformationen für Administratoren/ IT

Konfiguration Proxy-Server

Standardmäßig erkennt DESKTOP CONNECT die Proxyeinstellungen automatisch. Möglicherweise müssen sie jedoch manuell mit Angaben des Netzwerkadministrators vorgenommen werden.
Die Einstellungen werden in der Programmoberfläche (Start → think project! Desktop Connect) vorgenommen:

mceclip0.png

Mögliche Einstellungen:

  • Kein Proxy
  • Automatische Erkennung (Default)
  • Manuelle Proxy-Einstellung
    • Ohne Authentifizierung
    • Optional Authentifizierung

Verzeichnisse

Install-Dir C:\Program Files (x86)\think project!\ DesktopConnect
Ablage MSI C:\Users\[USER]\AppData\Roaming\think project!\DesktopConnect\install
(nur Admin, der installiert hat)
Config-Dir C:\Users\[USER]\AppData\Roaming\think project!\DesktopConnect
Log-Files C:\Users\[USER]\AppData\Local\Temp\think project!\DesktopConnect\Log
Temp-Dir C:\Users\[USER]\AppData\Local\Temp\think project!\DesktopConnect
(hier wird die zu bearbeitende Datei temporär gespeichert)

Wichtiger Hinweis zu Windows 10:
In manchen Fällen kann es passieren, dass – mit Standard-Einstellungen im Windows-Explorer – Dateien nicht im
Verzeichnis Temp-Dir gespeichert werden können. Hier kann es helfen, im Reiter „Ansicht“ des Explorers
„ausgeblendete Elemente“ einzublenden.
Hinweis: Die Konfigurationsdatei tpDesktopConnect.exe.config liegt zusätzlich im Programme-Verzeichnis unter C:\Program Files (x86)\think project!\DesktopConnect. Von dort wird sie mit den Default-Einstellungen in das UserVerzeichnis kopiert, falls sie dort nicht vorhanden ist. Zur Laufzeit von DESKTOP CONNECT wird sie immer aus dem oben angegebenen User-Verzeichnis geladen.

Debugging Commands

Sobald der Client installiert ist, können per Eingabe im Browser-Adressfeld bestimmte Informationen sowie Einstellungen per Command vorgenommen werden:

tpdc://info                     ruft die Programmoberfläche auf (wie unter Start → Programme …)
tpdc://tempdir               Zeigt den Pfad zum Arbeitsverzeichnis an

                                      (C:\Users\[USER]\AppData\Local\Temp\thinkproject!\DesktopConnect)
tpdc://checkmd5           Prüfsummen-Check beim Datei-Upload aktivieren bzw. deaktivieren
tpdc://splash                  Anzeige des Splash-Screens aktivieren bzw. deaktivieren

                                       mceclip1.png
tpdc://configdir              Zeigt den Pfad zur Konfig-Datei an (C:\Users\[USER]\AppData\Roaming\think
                                       project!\DesktopConnect)
tpdc://config                  Anzeige der Konfig-Datei „tpDesktopConnect.exe.config“ (damit das funktioniert,                                         muss die Dateiendung .config standardmäßig einem Texteditor zugewiesen sein)
tpdc://filelog                  Anzeige des Logfiles im Editor
tpdc://logging                Max Logging-Level aktivieren / deaktivieren
tpdc://stop                     Beendet den Client
tpdc://consolelog           Für 2nd-Level-Support: schreibt Konfig gleich in die Konsole

Logging aktivieren

Um alles zu loggen und Dateien nach dem Upload nicht automatisch zu löschen priority=“Max“ setzen in
C:\Users\[USER\[AppData\Roaming\think project!\DesktopConnect\tpDesktopConnect.exe.config): mceclip2.png

Workflow

Dateibearbeitung "Roundtrip"

Nach Klick auf das Bearbeiten-Icon wird die Datei in das lokale Nutzerverzeichnis herunter geladen. Die mit diesem Dateityp verknüpfte Anwendung öffnet die Datei automatisch:

mceclip0.png

Im Tray-Bereich wird der Status der Dateiübertragung angezeigt:

mceclip1.png

Während der Bearbeitung ist das Browser-Fenster gesperrt.

mceclip2.png

Nach Speichern der Datei klicken Sie auf Bearbeitung abgeschlossen, woraufhin die Datei hochgeladen wird.

 

Word Vorlagen

Erstellen Sie ein neues tpDC Dokument. 

Die Eigenschaften, deren Werte in die Word-Vorlage übernommen werden sollen, müssen in der Sende-Maske ausgefüllt werden:

blobid0.png

 

Klicken Sie auf Neu erstellen.
Anschließend werden die angegebenen Werte in die Word Datei übernommen.

 

Drucken

Drücken Sie auf das Drucker Symbol, damit wird der gesamte Inhalt der Datei auf Ihrem Standard-Drucker ausgegeben.

mceclip4.png

Fehlerbehebung

Firefox: Anwendung auswählen

Bei der ersten Verwendung muss Firefox mitgeteilt werden, mit welcher Anwendung ein tpdc-Link geöffnet werden soll. Hier muss think project! DesktopConnect ausgewählt werden.

mceclip5.png

Diese Einstellung kann in den Firefox-Einstellungen unter Anwendungen auch später angepasst werden.

mceclip6.png

 

Sicherheitsabfrage im Internet Explorer

Im Internet Explorer erscheint folgender Sicherheitshinweis zum Adresstyp „tpdc://“. Diesen Dialog mit Zulassen bestätigen:

mceclip7.png

Des Weiteren erscheint eine Warnmeldung zum tpDC-Client, die ebenfalls bestätigt werden muss. Beide Dialoge lassen sich bei späteren Aufrufen unterdrücken.

 

Sicherheitsabfrage in Chrome

Im Chrome muss folgender Dialog zum Erlauben des tpdc-Protokolls bestätigt werden.

mceclip8.png

Wenn dies nicht bestätigt wurde, kann im nachhinein ein Informationsfenster oben rechts in Ihrem Browser erscheinen. Dies kann mit einem Klick auf Fertig geschlossen werden.

 

Proxy Error

ERROR_WINHTTP_AUTODETECTION_FAILED … PAC/WDAT not found
Wenn Sie diese Nachricht (ERROR_WINHTTP_AUTODETECTION_FAILED) während des Arbeitens mit DESKTOP CONNECT erhalten, überprüfen Sie bitte Ihre Netzwerkeinstellungen. In der Regel ist die automatische Proxy-Erkennung angeschaltet.

Bitte schalten Sie diese aus.

Dies können Sie in den Netzwerk- und Interneteinstellungen der Systemsteuerung vornehmen.

mceclip9.png

Im Reiter Verbindungen wählen Sie LAN-Einstellungen.
Entfernen Sie das Häkchen bei Einstellungen automatisch erkennen.

mceclip10.png

 

Fehlerhafter Dateitransfer

Für den Fall, dass der Dateitransfer scheitert, erscheint im Tray-Bereich folgende Meldung:

mceclip11.png

Hier haben Sie die Möglichkeit, den Dateitransfer erneut zu starten oder den Client zu beenden.
Für mehr Details zu der Fehlermeldung klicken Sie auf Fehlerhafter Dateitransfer!

 

Speichern unter Windows 10 nicht möglich
In manchen Fällen ist es möglich, dass – mit Standard-Einstellungen – eine Datei nicht in tempdir gespeichert werden kann. Die Einstellung muss geändert werden, indem das Häkchen bei Ausgeblendete Elemente im Reiter Ansicht des Windows Explorers gesetzt wird.

mceclip12.png

 

Adobe Acrobat speichert Dateien nicht dort, wo sie ursprünglich liegen
Es ist möglich, das Verhalten, wie Adobe Acrobat Reader Dateien speichert, anzupassen.

  • Öffnen Sie Adobe Acrobat Reader DC auf Ihrem Computer
  • Gehen Sie zu Einstellungen unter dem Reiter Bearbeiten
  • Gehen Sie zu Sicherheit (erweitert)
  • Entfernen Sie das Häkchen bei Geschützten Modus beim Start aktivieren

mceclip13.png

  • Akzeptieren Sie die Warnung durch Klicken auf Ok
  • Klicken Sie auf Ok, um das Einstellungs-Fenster zu schließen
  • Starten Sie Adobe Acrobat Reader neu

Was nun passiert, wenn der Sie eine PDF Datei, die Sie im Adobe Reader bearbeitet haben, speichern wollen, ist, dass beim Klicken auf Speichern die Datei direkt gespeichert wird, ohne den „Speichern unter“ Dialog zu öffnen. Es muss also kein entsprechender Dateipfad mehr ausgewählt werden.
Dies könnte sich auf Ihre gewohnte Arbeitsweise auswirken. Bitte beachten Sie, dass dieses neue Verhalten nicht auf Dateien, die über den DESKTOP CONNECT bearbeitet werden, eingeschränkt ist

Einstellungen bei Fremdprogrammen

Adobe Acrobat Reader DC

Mit Einführung der Version Adobe Acrobat Reader DC, Version 2015 speichert der Adobe Acrobat Reader Dateien standardmäßig in der „Adobe Document Cloud“.
Vor der ersten Anwendung des DESKTOP CONNECT 3.0 muss folgende Einstellung im Adobe Acrobat Reader DC beachtet werden:

  • Öffnen Sie den Adobe Acrobat Reader DC auf Ihrem Rechner
  • Gehen Sie über Bearbeiten auf die Voreinstellungen

mceclip14.png

  • Unter der Kategorie Allgemein die Option Online-Speicher beim Speichern von Dateien anzeigen deaktivieren:

mceclip15.png

  • Jetzt können Sie mit der Anwendung des DESKTOP CONNECT 3.0 beginnen
  • Prüfen Sie bei den ersten Anwendungen des DESKTOP CONNECT 3.0, ob nach dem Prüfen
    im Adobe Reader die übernommene Datei Ihre Prüfkommentare und Anmerkungen enthält.

Screenshots sollten als Beispiel angesehen werden. Die Oberfläche Ihrer Plattform kann unterschiedlich aussehen, der Prozesse bleibt jedoch der Gleiche.

Einige der gezeigten Funktionen können, je nach Release Version Ihres Projektraumes, leicht abweichen.

War dieser Beitrag hilfreich?
0 von 0 fanden dies hilfreich

Benötigen Sie weitere Unterstützung? Kontaktieren Sie unser Support Team