Desktop Connect

The purpose of this article is to learn how to download Desktop Connect, use it correctly and deal with issues that might accrue. 

Desktops connect is used so that you can edit documents that you open within the project room and save them directly back into the project room, without having to download the document.

You can check with your Project Manager if the Project room facilitates Desktop Connect. If it does not and you wish to receive this, please discuss this with your Project Manager, who will have to send us a request if they are happy to receive this.

How to install Desktop Connect

First you need to download the Desktop connect file, which can be found at the bottom of this article.

The TP DC user is copied to the directory „C:\Program Files(x86)\think project!\DesktopConnect“.

The user must have read and write permission for all other directories which are mentioned in the chapter “Directories”.

Update:

The installation of the update works like the initial installation. The TP DC user is based on the installation of the Thinkproject instance.

There is a distinction made between minor and major updates:

Minor updates only make changes that do not affect the security of the software. Minor updates do not necessarily have to be installed.

Larger conversions come as a major update and are announced accordingly. They must be installed. Communication between the TP instance and an older client is prevented. With major updates, customers are forced to install the required update.

Language settings:

Program interface: System-dependent (the program interface is opened via Start > Thinkproject Desktop Connect

Messages in communications: project language of the thinkproject project.

 

Installation information for Administrator/ IT

Configuration of the proxy server:

Proxy settings are used to provide a browser or a client software such as DESKTOP CONNECT with the network address

of an intermediary server (called proxy server) which is used between the client and the internet. Proxy settings are

common in most corporate networks to connect to the internet.

Usually, DESKTOP CONNECT recognizes the proxy settings automatically. Maybe they have to be set up manually with information from the network administrator.

The settings are set up in the program interface (Start > Thinkproject Desktop Connect).

Possible settings:

  • No proxy
  • Automatic detection
  • Manual proxy setting
    • Without authentication
    • Optional authentication

Directories:

Install-Dir C:\Program Files (x86)\think project!\ DesktopConnect

MSI C:\Users\[USER]\AppData\Roaming\think project!\DesktopConnect\install

(only the installing admin)

Config-Dir C:\Users\[USER]\AppData\Roaming\think project!\DesktopConnect

Log-Files C:\Users\[USER]\AppData\Local\Temp\think project!\DesktopConnect\Log

Temp-Dir C:\Users\[USER]\AppData\Local\Temp\think project!\DesktopConnect

(working directory of the current file)

Caution with Windows 10:

In some cases it is possible that with the default settings a file cannot be saved in the directory Temp-Dir. This setting must be changed in the explorer tab “View” with the box “Hidden elements” checked.

Note: The configuration file lies in the program directory C:\Program files (x86)\think project!\DesktopConnect, too. From here, it gets copied to the user directory (together with the default settings), if it is not there yet. During DESKTOP CONNECT is running, the file will always be loaded from user directory.

Debugging:

Once the client is installed, certain information and setting can be set up by typing in the address field of the browser:

tpdc://info                       Calls the program interface

tpdc://tempdir                Shows the path to the working director                                                                                                            (C:\Users[USER]\AppData\Local\Temp\thinkproject!\DesktopConnect)

tpdc://checkmd5             Activate/deactivate checksum test before file upload

tpdc://splash                    Activate/deactivate splash-screen
                                          mceclip0.png

tpdc://configdir               Shows the path to the config file                                                                                                                       (C:\Users\[USER]\AppData\Roaming\thinkproject!\DesktopConnect)

tpdc://config                    Shows the config file „tpDesktopConnect.exe.config“ (for that, the file                                                           extension .config must be assigned to a text editor by default)

tpdc://filelog                    Shows the logfile in the editor

tpdc://logging                  Activate/deactivate maximum logging level

tpdc://stop                        Stops the client

tpdc://consolelog             For 2nd level support: Config immediately writes into the console

 

Activate Logging:

In order to log everything and to not delete automatically after upload set priority=”Max” in

C:\Users\[USER\[AppData\Roaming\think project!\DesktopConnect\tpDesktopConnect.exe.config):

mceclip1.png

his is where you put the text you want to appear when dropping down the accordion.

Workflow

File processing (“roundtrip”)

With clicking on the edit icon, the file is downloaded to the local user directory. The application linked with this file type opens the file automatically:

mceclip2.png

They tray area displays the status of the file transfer:

mceclip3.png

During editing, the browser window is locked:

mceclip4.png

After saving the file and closing the application, the user clicks on “Editing completed” after which the file is uploaded.

 

Word templates

Click on Send new.

The properties which values shall be taken over into the Word template have to be filled out.

Then click on Create In the file selection.
mceclip5.png

The filled in values will then be taken over into the Word template.

Print

By clicking on print, the entire content of the file is sent to the default printer.
mceclip6.png

 

Error Handling

Firefox: Select application

On first use, Firefox must be told which application has to be used when a TP CD link is opened. Here, Think project DesktopConnect must be selected:
mceclip7.png

This setting can then be adjusted afterwards in the Firefox settings under Options > General > Applications:

mceclip8.png

Security query in Internet Explorer:

In the Internet Explorer, the following security notice appears for the address type tpdc://. Confirm this dialogue with Allow.
mceclip9.png

Sometimes, a warning message appears which also must be confirmed. Both dialogues can be suppressed for later calls.

Security query in Google Chrome:

In Chrome, the following dialogue for allowing the TP CD protocol must be confirmed:
mceclip10.png

If the user had already click on “Do nothing”, an aftereffect might appear. This would just be an information in the top right corner which can be clicked away by clicking on Done.

Proxy-error:

ERROR_WINHTTP_AUTODETECTION_FAILED … PAC/WDAT not found

If you get this message (ERROR_WINHTTP_AUTODETECTION_FAILED) while working with DESKTOP CONNECT please check your network connection settings. Most likely Auto-Proxy-Detection is turned on in the system. Please turn it off.

You can do this in the Control Panel > Internet Options:
mceclip11.png

Go to tab Connections and click on LAN settings.

Disable Auto-Proxy-Detection here:

mceclip12.png

Failed file transfer:

In case the file transfer fails, the user has the option of restarting the file transfer or closing the client.

For more details about the error click on failed file transfer.

Please contact your administrator if you need further help.

 

No saving possible with Windows 10:

In some cases, it is possible that – with default settings – a file cannot be saved in tempdir. The setting must be changed by ticking the checkbox Hidden items in the View tab of your explorer window.

mceclip13.png

Adobe Acrobat does not save file in the location where the original file is:

We did not figure out why some Adobe Readers save files in the current folder and why some do not. But you can change the behavior of how Adobe Acrobat Reader saves files (s. next page).

 

  • Open the Adobe Acrobat Reader DC on your computer
  • Go to Preferences via Edit
  • Go to Security (enhanced)
  • Uncheck the box next to Enable Protected Mode at startup
    mceclip14.png
  • Accept the warning by clicking on Ok
  • Click on Ok to close the settings window
  • Restart Adobe Acrobat Reader

What now will happen when the user saves a PDF file that they edited in the Adobe Reader, is that with clicking on Save the file will be directly saved without the “Save as” dialogue being opened. There is no need any more for choosing the respective file path at all.

Please make sure to explain this new behavior to the user – they might be used to the old behavior.

 

Settings for Foreign Programs

Adobe Acrobat Reader DC:

With the introduction of the Adobe Acrobat Reader DC, version 2015, the Adobe Acrobat Reader stores files by default in the Adobe Document Cloud.

Before using DESKTOP CONNECT for the first time, the following setting must be checked In the Adobe Acrobat Reader

DC:

  • Open the Adobe Acrobat Reader DC on your computer
  • Go to Preferences via Edit
    mceclip15.png
  • Under the category General deactivate the option Show online storage when saving files.
    mceclip16.png
  • You can now start using DESKTOP CONNECT
  • When you are using DESKTOP CONNECT for the first time, please check if the imported file contains your review comments and notes after checking it in the Adobe Reader

Screenshots are an example. The interface of your platform may look different, but the processes remain the same.

Some of the functions shown may differ slightly depending on the release version of your project room.

Was this article helpful?
0 out of 0 found this helpful

Need further help? Contact our Support Team