Desktop Connect

L'article suivant explique comment télécharger et utiliser correctement Desktop Connect et comment résoudre les messages d'erreur.

Desktop Connect est utilisé pour modifier et redéfinir des documents directement dans l'espace projet, sans devoir les télécharger.

Votre responsable de projet peut vous indiquer si Desktop Connect est configuré sur votre espace projet. Si ce n'est pas le cas et qu'une connexion à Desktop Connect est nécessaire, veuillez en discuter avec votre chef de projet. Celui-ci doit envoyer une demande à notre équipe afin de discuter de la mise en place sur l'espace de projet.

Comment installer Desktop Connect

Téléchargez d'abord le fichier d'installation Desktop Connect, vous le trouverez à la fin de cet article.

Lors de l'installation, le client TP DC est copié dans le répertoire "C:\Program Files(x86)\think project!\DesktopConnect".
En outre, il doit y avoir un accès en lecture et en écriture à tous les autres répertoires indiqués plus bas sous "Répertoires".

Mise à jour

L'installation de la mise à jour fonctionne comme la première installation. Le client TP DC est basé sur l'installation de l'instance Thinkproject. En principe, on distingue les mises à jour mineures et les mises à jour majeures.
Dans le cas des mises à jour mineures, seules les modifications qui n'affectent pas la sécurité du logiciel ont été effectuées. Les mises à jour mineures ne doivent pas nécessairement être installées.
Les mises à jour de sécurité ou les transformations plus importantes arrivent en tant que mises à jour majeures et sont annoncées en conséquence. Elles doivent être installées. La communication entre l'instance TP et un client plus ancien est interrompue.

Pour les mises à jour majeures, l'utilisateur est obligé d'installer la mise à jour nécessaire.

Paramètres de langue

Interface du programme : dépend du système (l'interface du programme s'ouvre via
Démarrer → Programmes → Thinkproject Desktop Connect).
Messages lors de la communication : langue du projet Thinkproject

Informations d'installation pour les administrateurs / IT

Configuration du serveur proxy

Par défaut, DESKTOP CONNECT détecte automatiquement les paramètres du proxy. Il se peut toutefois qu'ils doivent être définis manuellement avec les indications de l'administrateur réseau.
Les paramètres sont définis dans l'interface du programme (Démarrer → think project ! Desktop Connect) :

mceclip0.png

Paramètres possibles:

  • Pas de proxy
  • Détection automatique (par défaut)
  • Réglage manuel du proxy
    • Sans authentification
    • Authentication facultative

Répertoires

Install-Dir C:\Program Files (x86)\think project!\DesktopConnect
Stockage MSI C:\Users\[USER]\AppData\Roaming\think project!\DesktopConnect\install
(Admin seulement, qui a installé)
Config-Dir C:\Users\[USER]\AppData\Roaming\think project!\DesktopConnect
Log-Files C:\Users\[USER]\AppData\Local\Temp\think project!\DesktopConnect\Log
Temp-Dir C:\Users\[USER]\AppData\Local\Temp\think project!\DesktopConnect
(le fichier à traiter est enregistré ici de manière temporaire)

Remarque importante concernant Windows 10:
Dans certains cas, il peut arriver qu'avec les paramètres par défaut de l'Explorateur Windows, les fichiers ne puissent pas être enregistrés dans le répertoire Temp-Dir. Dans ce cas, il peut être utile d'afficher des "éléments masqués" dans l'onglet "Affichage" de l'explorateur.
Remarque: Le fichier de configuration tpDesktopConnect.exe.config se trouve également dans le répertoire des programmes sous C:\Program Files (x86)\think project!\DesktopConnect. De là, il est copié avec les paramètres par défaut dans le répertoire utilisateur s'il n'y est pas présent. Lors de l'exécution de DESKTOP CONNECT, il est toujours chargée à partir du répertoire utilisateur indiqué ci-dessus.

Commandes de débogage

Dès que le client est installé, il est possible de saisir certaines informations et paramètres dans le champ d'adresse du navigateur via une commande :

tpdc://info                     Appelle l'interface du programme (comme sous Démarrer → Programmes ...)
tpdc://tempdir               Affiche le chemin d'accès au répertoire de travail (C:\Users\[USER]\AppData\Local\Temp\thinkproject!\DesktopConnect)
tpdc://checkmd5           Active ou désactive la vérification du checksum lors du téléchargement de fichiers
tpdc://splash                  Active ou désactive l'affichage de l'écran splash

                                       mceclip1.png
tpdc://configdir              Affiche le chemin d'accès au fichier de configuration (C:\Users\[USER]\AppData\Roaming\think project!\DesktopConnect)
tpdc://config                  Affiche le fichier de config "tpDesktopConnect.exe.config" (pour que cela fonctionne, l'extension de fichier .config doit être attribuée par défaut à un éditeur de texte)
tpdc://filelog                  Affiche le fichier journal dans l'éditeur
tpdc://logging                Active ou désactive le niveau de journalisation maximum
tpdc://stop                     Ferme le client
tpdc://consolelog           Pour le support de 2ème niveau : écrit la config directement dans la console

Activer le journal

Pour tout journaliser et ne pas supprimer automatiquement les fichiers après leur téléchargement, mettre priority="Max" dans
C:\Users\[USER\[AppData\Roaming\think project!\DesktopConnect\tpDesktopConnect.exe.config): mceclip2.png

Fonctionnement

Édition de fichiers

Après avoir cliqué sur l'icône d'édition, le fichier est téléchargé dans le répertoire local de l'utilisateur. L'application associée à ce type de fichier ouvre automatiquement le fichier:

mceclip2.png

L'état du transfert de fichier est affiché dans la zone de notification:

mceclip3.png

Pendant le traitement, la fenêtre du navigateur est verrouillée.

mceclip4.png

Après avoir enregistré le fichier, cliquez sur Modification achevée, après quoi le fichier est téléchargé.

 

Modèles Word

Créez un nouveau document tpDC. 

Les propriétés dont les valeurs doivent être reprises dans le modèle Word doivent être remplies dans le masque d'envoi.
Cliquez sur Créer.

mceclip5.png

 

Les valeurs indiquées sont ensuite reprises dans le fichier Word.

 

Imprimer

Appuyez sur l'icône de l'imprimante pour que tout le contenu du fichier soit imprimé sur votre imprimante standard.

mceclip6.png

Dépannage

Firefox: sélectionner une application

Lors de la première utilisation, il faut indiquer à Firefox avec quelle application un lien tpdc doit être ouvert. Ici, think project ! DesktopConnect doit être sélectionnée.

mceclip7.png

Ce paramètre peut également être modifié ultérieurement dans les paramètres de Firefox sous Applications.

mceclip8.png

 

Notification de sécurité dans Internet Explorer

Dans Internet Explorer, la notification de sécurité suivante apparaît pour le type d'adresse "tpdc://". Confirmer ce dialogue en cliquant sur Autoriser :

mceclip9.png

En outre, un message d'avertissement concernant le client tpDC apparaît et doit également être confirmé. Les deux boîtes de dialogue peuvent être supprimées pour les fois suivantes.

 

Notification de sécurité dans Chrome

Dans Chrome, la boîte de dialogue suivante doit être confirmée pour autoriser le protocole tpdc.

mceclip10.png

Si cela n'a pas été confirmé, une fenêtre d'information peut s'afficher ultérieurement en haut à droite de votre navigateur. Cette fenêtre peut être fermée en cliquant sur Terminé.

 

Erreur de proxy

ERROR_WINHTTP_AUTODETECTION_FAILED … PAC/WDAT not found
Si vous recevez ce message (ERROR_WINHTTP_AUTODETECTION_FAILED) pendant que vous travaillez avec DESKTOP CONNECT, veuillez vérifier vos paramètres réseau. En règle générale, la détection automatique de proxy est activée.

Veuillez la désactiver.

Vous pouvez le faire dans les paramètres réseau et Internet du panneau de configuration.

mceclip11.png

Dans l'onglet Connexions, sélectionnez Paramètres réseau.
Décochez la case Détecter automatiquement les paramètres de connexion.

mceclip12.png

 

Erreur de transfert de fichiers

En cas d'échec du transfert de fichiers, le message suivant apparaît dans la zone de notification:

mceclip11.png

Vous avez ici la possibilité de relancer le transfert de fichiers ou de quitter le client..
Pour plus de détails sur le message d'erreur, cliquez sur failed file transfer!

 

Impossible d'enregistrer sous Windows 10
Dans certains cas, il est possible - avec les paramètres par défaut - qu'un fichier ne puisse pas être enregistré dans tempdir. Le paramètre doit être modifié en cochant la case Éléments masqués dans l'onglet Affichage de l'Explorateur Windows.

mceclip13.png

 

Adobe Acrobat n'enregistre pas les fichiers à l'endroit où ils se trouvent à l'origine
Il est possible de configurer la façon dont Adobe Acrobat Reader enregistre les fichiers.

  • Ouvrez Adobe Acrobat Reader DC sur votre ordinateur.
  • Allez dans Préférences sous l'onglet Édition
  • Allez dans Protection (renforcé)
  • Décochez la case Activer le mode protégé au démarrage

mceclip14.png

  • Acceptez l'avertissement en cliquant sur Ok
  • Cliquez sur Ok, pour fermer la fenêtre des paramètres
  • Redémarrez Adobe Acrobat Reader

Ce qui se passe maintenant lorsque vous voulez enregistrer un fichier PDF que vous avez édité dans Adobe Reader, c'est que lorsque vous cliquez sur Enregistrer, le fichier est enregistré directement sans ouvrir la boîte de dialogue "Enregistrer sous". Il n'est donc plus nécessaire de sélectionner un chemin de fichier correspondant.
Cela pourrait avoir un impact sur votre méthode de travail habituelle. Veuillez noter que ce nouveau comportement n'est pas limité aux fichiers traités via DESKTOP CONNECT.

Paramètres pour les programmes tiers

Adobe Acrobat Reader DC

Avec l'introduction de la version Adobe Acrobat Reader DC, version 2015, Adobe Acrobat Reader enregistre par défaut les fichiers dans l'"Adobe Document Cloud".
Avant d'utiliser DESKTOP CONNECT 3.0 pour la première fois, il faut tenir compte du réglage suivant dans Adobe Acrobat Reader DC:

  • Ouvrez Adobe Acrobat Reader DC sur votre ordinateur
  • Allez dans les Préférences via Édition

mceclip15.png

  • Sous la catégorie Général, désactivez l'option Afficher le stockage en ligne lors de l'enregistrement de fichiers:

mceclip16.png

  • Vous pouvez maintenant commencer à utiliser DESKTOP CONNECT 3.0.
  • Lors des premières utilisations de DESKTOP CONNECT 3.0, vérifiez si, après le contrôle dans Adobe Reader, le fichier transféré contient vos commentaires de contrôle et vos annotations.
Cet article vous a-t-il été utile ?
Utilisateurs qui ont trouvé cela utile : 0 sur 0

Vous avez besoin d'aide? Contactez notre équipe de support